installing nightmare


Author: yifei / Created: Jan. 18, 2018, 6:50 a.m. / Modified: Jan. 18, 2018, 2:51 p.m. / Edit

electorn bugs

It's because electorn uses a prebuilt file which is located at github, and with GFW, the network offen times out. use taobao mirror to avoid this.

export ELECTRON_MIRROR="https://npm.taobao.org/mirrors/electron/"

npm cache clean

rm $HOME/.electron   # rm electorn local cache
rm .npm

sudo apt-get install libgtk2.0-0 libnotify-bin libgconf-2-4 libnss3

npm install electron -g

评论区